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Chapter 1.  Introduction

Objective of Freight Transportation Modeling in Iowa
The Iowa DOT has been involved in freight transportation modeling efforts since the early

1970s.  Freight modeling efforts to date has focused primarily on the development of grain forecasting
models.  However, the Iowa DOT has become increasingly more interested in developing multimodal,
tactical models capable of modeling movements of several commodities.  The overall objective of the
Department is to simulate the impacts of changes in transportation and non-transportation service
variables on freight movements and, within this framework, investigate industry location decisions, the
rational behind commodity movements, and public policy impacts on freight movements.  

Project Objective
The goal of this project is to develop a tactical model of freight transportation demand in Iowa

that will consider all modes of transportation as well as the most important commodities.  The primary
function of this planning tool will be analyzing the potential impacts of policy and industry changes on
freight transportation within the State.

The tool is capable of providing priority listings of state roads and their importance to various
industry sectors.  Hence, the tool can be used to support policy decisions related to the maintenance
and improvement of selected state highways.  The tool is also expected to be useful in responding to
ISTEA statewide planning requirements (in Iowa, addressed in part by the Iowa in Motion program)
including  intermodal, rural economic growth and State Transportation Improvement Program (STIP)
provisions.  Specifically, the model is useful as it can respond (in a limited way) to various exogenous
forecasts of economic activity in a region of the state by forecasting amounts of freight expected to be
hauled on state highways.  Using these estimates, the Iowa DOT can make more informed decisions
about allocation of construction and maintenance dollars - investments that support selected state
economic development objectives

Model Overview
Our approach to freight transportation modeling is built using layers, with each layer

representing goods moved by a separate industry or economic sector.  Because firms with similar
attributes that ship similar goods are likely to have similar transportation requirements, freight
transportation demand lends itself to this approach.  After developing the layers for each economic
sector, these layers can be overlaid to cumulatively result in an entire model of a state's or a region's
freight transportation flow.

Obviously, in order to apply this layered approach to freight transportation modeling, the
industries, or economic sectors, of interest and the locations of freight generators within these industries
must be identified.  Additionally, the infrastructure available (e.g. highways, rail, and waterways) for
commodity movement to and from the freight generators must also be identified.

Since industries may utilize the various available modes to varying degrees and may be sensitive
to different factors, commodity movements within each industry must be assessed.  It is necessary to
assess not only how a commodity moves, but why it moves in the manner in which it does.  An
understanding of how a commodity moves, and how these movements are affected by various factors,
provides the framework for developing a model sensitive to policy variables.  The model is responsive
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to public investments, public initiatives in general, changes in transport prices, changes in industry
location, and restrictions on routes.  The sensitivity of the model to such variables facilitates analysis of
how the State's economic position, by commodity, relates to or is impacted by transportation services in
the State.

Furthermore, development of the model takes into account the steps necessary for migration
from concept to application.  All program activities ensure that end users are confident in their ability to
use the models and methodologies, and that individual projects will define user training requirements,
level of effort required for application maintenance, and level of effort required to maintain supporting
databases.  All transportation modeling activities are built on a transportation system network, and make
good use of existing Iowa DOT and other State agency-supported databases.

Report Contents
This report consists of six chapters and two appendices.  Chapter 1 introduces the Iowa DOT's

freight transportation modeling objectives, the objective of this project specifically, and the framework
of the model.  Chapter 2 provides an overview of the state of the practice in freight transportation
modeling, including the Iowa DOTs efforts over the past three decades.  Chapter 3 describes the two
primary approaches to freight transportation modeling and outlines the approach used to develop the
model in this project.  Chapter 4 covers model development and methodology, while Chapter 5
discusses the potential impacts the model may have on the Iowa DOT.  Chapter 7 concludes the report
and addresses how well the model works with respect to the stated objectives as well as how the model
relates to the Department's overall freight modeling objectives.  Report appendices include model
developer and users guides.  Other pertinent information, not provided in this report, includes NCHRP
Report 388, "A Guidebook for Forecasting Freight Transportation Demand (1997)" and Reebie
Associate's "TRANSEARCH Reference Manual," providing, respectively, an extensive review of freight
transport demand literature and data sources useful in freight planning.  In addition, Ted Smith's 1995
Master's Thesis for Iowa State University, "An Information Engineering approach for the coordinated
development of statewide multi-modal transportation forecasting models," provides a thorough review
of the information engineering approach to modeling.
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Chapter 2.  State of the Practice

Methods used to model freight transportation demand can be categorized into two general
types: spatial price equilibrium and network equilibrium.  Spatial price equilibrium methods were used to
model interregional freight flows.  These models determine the flow between production and
consumption regions by using demand and supply functions and, in addition, estimate commodity selling
and buying prices (1).  Spatial price equilibrium models use a simplistic representation of the
transportation network.  They primarily use econometrics methods to estimate supply and demand
functions of the produced or consumed commodities.  Previous applications of these models were
mainly agricultural or energy related (1).

Transportation network models have been used since the early 1960s to analyze flow among
origin-destination pairs connected by a finite network of transportation facilities.  And, while most of
these network applications were conducted to support urban transportation planning, early freight
network models were developed in the late 1960s(2).

The Harvard-Brookings model, considered the first freight network model, was developed by
Roberts in 1966 and later modified by Roberts and Kresge in 1971 (3).  The model explicitly related
transportation decisions to economic and spatial factors and the theoretical component in the model
presented an innovative method of estimating freight flows.  However, the micro-level details in the
model formulation and its extensive data requirements inhibit a practical application of the model. 

Guelat, et al. developed a network model for simulating freight flows on Brazil's transportation
network (1). The model considers multiple products by specifying a cost function for the flow of each
product on a link or through a transfer that corresponds to one mode. The demand and modal choices
for each product were obtained from a set of origin-destination matrices (1).

Rahman and Radwan developed a decision support system as a highway freight planning tool to
enable the Arizona Department of Transportation to evaluate the performance of the highway network
under different economic and regulatory scenarios.  The criteria used for evaluating the impacts on the
highway network relate estimated freight traffic levels to network utilization, number of accidents, and
highway maintenance costs (4). The model estimates truck commodity flow patterns (in ten classes)
based on a sampling of truck shipments.  

Russell, et al. developed a model for estimating highway commodity flows and ESAL
(equivalent single axle load) values in Kansas (5).  The study focused on the highway mode and five
agricultural commodities: wheat, corn, sorghum, soybeans, and boxed beef.  The study relied on
commodity flow data assembled from surveys.  The study used QRS II to assign truck trips to shortest
time paths.  

As most network models treat freight transportation demand and distribution as exogenous, the
lack of appropriate or adequate commodity flow data is a critical issue in freight transportation planning.
There is also a shortage of practical planning tools to study truck commodity flows.  Applying network
or spatial price equilibrium models to predict truck traffic distribution requires extensive modal
performance data.  Generally, such applications  are too theoretical (difficult for planning staff to fully
comprehend), and data intensive for state needs.  Applications of existing freight models have been, at
best, general.  Results were not properly validated or utilized in an intermodal freight transportation plan.
Many of the weaknesses in modeling capabilities in freight transportation planning are attributable to
data availability.  And, while the methodological tools can be applied when appropriate data are
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available, the difficulty lies in tailoring these methodologies to a specific planning problem given limited
data.

A table of the compiled various state efforts and their status are provided below.

Table 1.  State Freight Modeling Efforts and Status.

Completed feasibility study and
recommended not developing
models at this time. (1994)

pivot point (trend extrapolation)Texas

Completed initial feasibility study
and awaiting funding (1994); lack
of data

workshop developed conceptual
framework

New Mexico

Updating and calibrating existing
model.  Expanding to intermodal
and border counties.

Passenger Vehicle Forecasts,
1000 Zones, MINUTP

Kentucky

Updating and calibrating existing
model 

Passenger Vehicle Forecasts
(connects simplified existing MPO
models)

Florida

In the process of updating and
calibrating existing model.

Multimodal (ground) multiphase,
2300 zone TransCAD (most
extensive effort identified)

Michigan

Wants to use for NAFTAPassenger (QRSII to Tranplan), 6
TAZs

Wyoming

developing comprehensive
multi-modal model
Oracle/ArcView

Multi-modal to support
Intermodal Management System 

California

Translinks 21: state/county forecast
refined by expert panel

Passenger and Freight
Movements. Intrastate and
adjacent counties/major corridors

Wisconsin

STATUS OF MODELING
PROGRAM

MODES/MODEL
SPECIFICATION

(Source: Phone interviews with DOTs as suggested by FHWA regional planning staff.)

The review of the efforts of other states provided a thorough background of the practical
limitations that would apply in a modeling effort.  Detailed descriptions of the methods and procedures
are provided in the aforementioned Smith Masters Thesis.
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Past Iowa DOT Statewide Planning Activities
As part of the modeling activities undertaken, it was essential to ascertain past statewide

planning efforts undertaken by the IDOT.  Personnel from the DOT were contacted for such
information and a listing of the activities undertaken follow: 

P A statewide traffic model  was built on the patterns of the four step traditional modeling
techniques and calibrated in the early 1970s.  Trip generation in process was based on population
and employment variables.

P Most of the freight planning activities were focused on grain movement.  A benefit/cost model
was developed to assist staff in analyzing rail abandonments and to determine where limited state
branchline assistance funds should be invested.

P Occasional studies to address specific truck-related issues such as speed limit changes, truck
length and weight restrictions, etc. are conducted.

P On-going planning process with the Corps of  Engineers to guide investments in the lock and dam
system in the Mississippi River.

P Site-related studies that result in improvements to the primary highway system in reaction to a
locational decision by an industry.

P Analysis of truck traffic for consideration in the determination of the determination of the 5-level
stratification of the state primary highway system, including the CIN system, and the
determination of the NHS system for Iowa. 

6



Chapter 3.  Modeling Approach

Information Engineering  
The information engineering approach concentrates on arriving at general procedures that can

be useful for any type of planning activity.  Although the approach is useful  for developing administrative
tools for coordinating data elements and information systems, the approach is too general for freight
transportation modeling and would be unable to answer specific questions expected of the model.  A
thorough review of the information engineering approach was conducted for this project and written by
Smith as a Masters Thesis for Iowa State University.  Because of the limitations of the information
engineering approach, the onion model became the most viable modeling option.

Onion Model 
In freight transportation a wide variety of goods are moved with heterogeneous attributes and

transportation requirements.  Therefore modeling all commodities simultaneously in one demand model
is probably unrealistic.  Also, congestion is not a key issue for intercity freight transportation.  Because
congestion is not a critical issue, there is no need to simultaneously load all traffic on modeled
infrastructure links simultaneously.  Together, these two issues present compelling reasons for
segmenting freight traffic by commodity or economic sector.  Each segment becomes a layer, and
together all the layers (or the majority of the layers) provide an aggregate estimate of all freight traffic.
Use of the onion model in the development of a statewide or regionwide freight demand modeling tool
requires adhering to the following steps and procedures:

P Identify the economic sectors and subsectors which generate the most freight traffic with the
geographic region.  By developing freight transportation planning tools incrementally, with one
group of similar commodities at a time, the analysis should focus on predominant economic
sectors first.

P Identify the data requirements to support the development of freight transportation analysis tools.
When identifying data requirements it is important to recognize there are likely to be limited data,
and, therefore, it is important to narrowly focus data requirements while ensuring that freight
transportation planning goals and objectives may be supported.

P In contrast to the previous step, this step involves identifying the availability of data and designing
instruments for collection of unavailable data.   Data needed to support the freight transportation
demand modeling process are likely to be derived from a wide variety of sources aggregated
over different geographical coverages and over different time periods.  The difficulty is in seeking
out sources of information and  being able to disaggregate or aggregate them into a form which is
meaningful for analysis.

Upon careful review of both approaches, the onion model was selected as the approach for use
in the development of the freight transportation model.   Several factors influenced this selection.
Obviously, a major factor was the limitations of the information engineering approach.  Another major
factor was the onion model's ability to accommodate some of the basic assumptions appropriate for the
modeling effort, such as the assumption that intercity freight transportation need not consider congestion
as one of the factors.  Lastly, the onion model adequately satisfied the following approach evaluation
criteria: 
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P The approach confirms to the notion of evolving a strategy that suits available data.
P The methodology represents a straight forward approach and tries to minimize the level of effort

on the part of the user. 
P The approach is oriented toward  IDOT decision support staff that need to understand and

subsequently  implement the model.
P Existing databases were used to reduce the formation of "orphan" databases.
P The selected approach also benefits from the fact that the proposed model is a tactical model

rather than being a strategic model, this help the DOT in analyzing what-if situations.
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Chapter 4.  Model and Methodology Development Overview 

Building the Freight Transportation Model
As previously mentioned, we have followed a layered approach in building a freight

transportation model for Iowa.  This is based on the assumption that the demand for truck
transportation in one economic sector is independent of truck transportation demand from other
economic sectors and, therefore, they can be modeled separately.  For example, the demand for
transportation to ship meat products is unrelated to the demand for truck transportation service to carry
construction machinery.  In addition, when trucks carrying traffic from different industry segments are
assigned to the transportation network, they interact independently with the transportation system (i.e.,
congestion is not an issue).  Further, the economic activity producing truck traffic is not uniformly
distributed across an entire state or region and is concentrated within a few locations, allowing further
segmentation by location.  

Case Study
In order to demonstrate the effectiveness of the proposed modeling technique and to begin to

make model improvements, the methodology is applied to one commodity group.

Identify Goals
The goal of the case study application is to provide the Iowa DOT with a planning tool which

will be capable of providing priority listings of state roads and their importance to various industry
sectors.  Hence, the tool will be used to support policy decisions related to the maintenance and
improvement of selected state highways.  The tool is also expected to be useful in responding to ISTEA
statewide planning requirements (in Iowa, addressed in part by the Iowa in Motion program) including  
intermodal, rural economic growth and State Transportation Improvement Program (STIP) provisions.
Specifically, it would be useful if the model could respond to various exogenous forecasts of economic
activity in a region of the state by forecasting amounts of freight expected to be hauled on state
highways.  Using these estimates, the DOT could make more informed decisions about allocation of
construction and maintenance dollars - investments that support selected state economic development
objectives. 

Development of the model should take into account the steps necessary for migration from
concept to application.  All program activities will ensure that end users are confident in their ability to
use the models and methodologies, and that individual projects will define user training requirements,
level of effort required for application maintenance, and level of effort required to maintain supporting
databases.  All transportation modeling activities are to be built on a transportation system network, and
make good use of existing Iowa DOT supported databases.
Identify Layers

Using data on total freight flow volumes for the state (6), commodity groups with the most
impact on Iowa transportation were identified.  These commodities, by decreasing order in terms of
total tonnage are grain, meat products and machinery.  As a grain flow model is currently being
developed by faculty in Iowa State University's Department of Economics, freight flow in the meat
packing industry was chosen as the first layer.  As identified by Russell (5), meat products are
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exclusively handled by truck.  Therefore, the first layer of our model represents a single commodity and
a single mode of transport.

Identify data and then find model form
This section describes the process used by the research team to develop a statewide freight

flow model for the first commodity, or layer (meat packing industry).  While the conventional urban
modeling process is a well known four step process, we perform only two of these steps for our first
model layer (trip distribution and traffic assignment).  Trip generation is omitted as we intend to forecast
future trip pairs as a function of existing flows and factor traffic up or down using zonal growth factors
(using, say, a Fratar model).  In the meat packing example, non-highway modes represent a negligible
portion of total flows.  Therefore, explicit modal choice modeling is not required.

Step 1: Available Data: Reebie and Associates collects and maintains an extensive nationwide freight
flow (OD) database.  The data are organized by Business Economic Areas (BEA) designated by the
Department of Commerce.  Each BEA typically represents a major economic center (for example, there
are six BEAs in Iowa). The Reebie data provided for this project include origin state, origin BEA and
destination state, destination BEA for each OD pair. The data are further classified by Standard
Industrial Commodity code (SIC) and shipping mode. Truck flows are classified by type of carrier
(for-hire, private) and by shipment type (container, bulk, or LTL). 

While most geographic information system (GIS) databases can store origin-destination (OD)
data, their data structures are such that linking the pair data to geographic features is not easily
accomplished, nor is conversion between the standard record/item format to a matrix format (required
by most travel demand models) routinely provided for.  Therefore, the OD pair data are stored in a
relational database (Lotus Approach).  During the development of each model, data for a particular
commodity/shipment type can be extracted (into a text file format) from the database for relevant modes
(e.g., truck transportation is mainly used in the meat packing industry). 

Although the data met our  requirements and was very useful, the following limitations are
noteworthy:

P Data does not include shipments from warehouses and other sources of secondary movements.
P Truck shipments of  non-manufactured goods not included.
P Only raw materials reported for truck is coal.
P TOFC/COFC is underreported by commodity.
P For additional limitations refer to TRANSEARCH Reference Manual; page 10. 

Step 2: TAZ Structure: To facilitate use of a commercial travel demand model for traffic assignment,
travel demand must be aggregated into zones (TAZs).  The zonal structure of the Reebie data provided
for Iowa was BEA (within and near Iowa) and regions (aggregated BEAs) which are proportionally
larger with distance from Iowa.  This construct provides a reasonable level of aggregation outside of
Iowa, but is too coarse (six BEAs) within the state to identify flows on roads of interest to State
decision makers.  Therefore, counties were used as TAZs within the State (99 counties).  Some BEAs
also cross state borders.  In the case where a BEA crossed the Iowa border, Iowa counties are
removed and the remainder of the BEA comprises one TAZ.  This procedure provides for a total of  
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145 TAZs in the model.  The TAZ definition was then used to create a map/table in MapInfo (MapInfo
is a desktop computer GIS program).

Step 3:  Network Development: A network consisting of the U.S. Interstate System was combined
with Iowa Primary (State-owned) roads.  The total network represents about 40,000 miles of roads
outside Iowa and some 10,000 miles of road inside the State.  In MapInfo, the two network
components were combined and attributed with free-flow speed.  In the "combined" network, many
Iowa primary highways appeared to terminate at the state border.  In reality, these roads, in most cases,
continue on as other state's highways.  However, inclusion of other state's highways would lead to the
development of a large, unwieldy network.  Further, this level of detail was not considered important to
representing accurate network flows inside Iowa.  An assumption was made that once outside Iowa,
trucks would choose to travel the interstate system, and take the shortest path to this system (if they
hadn't already made it to an Interstate before exiting the state).  To represent this assumption in the
model, "artificial" connectors were added outside the Iowa border which represent reasonable paths to
the nearest Interstate highway (in fact, these connectors follow actual state highway routes, but do not
reflect all such possible routes).  Finally, centroid connectors were added to tie TAZs to the network.  

This "link only " MapInfo network is then converted to a Tranplan (Tranplan is a common travel
demand modeling computer program) format, link-node network (using some routines written by
project staff).  The routines prepare a new MapInfo map/table and automatically populate its link
database with beginning and ending node numbers, Cartesian coordinates, length, speed, link ID and
highway name. The nodes table is also automatically attributed with node number and coordinates.

Step 4: Disaggregation of Data into TAZ Structure: For the meat-packing industry, it is assumed that
freight origins are proportional to the number of persons employed in a given location.  Therefore,
employment data (number of employees, SIC code, etc.) are used to disaggregate origin data from
BEA-level into the county level.  Destinations, on the other hand, are assumed to track population as a
whole.  County population estimates are then used to disaggregate destination totals.  Simple, GIS
database queries are used to determine the proportions of origins and destinations in each county/TAZ
and these proportions are then used to develop a more detailed, OD matrix in Tranplan format (using
additional routines). 

Step 5: Model Run: An interface between MapInfo and Tranplan was developed to allow the use of
GIS to store and update data as well as to calibrate the models and visualize model results.  Once the
network and TAZ data have been developed as described above, obtaining output from the system
takes only a few minutes.  The process consists of six steps.  First, the link and node network from the
GIS are exported into text files. Second, a FORTRAN program uses the text files to prepare input with
which Tranplan encodes the network.  Third, a FORTRAN program is run to convert the base-year
OD table to Tranplan format.  Fourth, TRANPLAN is used to assign the trips to the network, using an
all-or-nothing assignment (which assumes no effect of congestion on route decisions).  Fifth, the
Tranplan output (network loadings) are exported into text files, and sixth, the GIS link database is
updated with truck flows.
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Step 6: Validate: As an initial attempt at model validation, truck flows in the meat packing industry in
Iowa were compared with DOT estimates of total truck flows on state highways.    DOT planning staff
was asked to assess the reasonableness of the model results.  While inconclusive, these assessments did
not identify any obvious model flaws - the flows seem reasonable.  A next step is to demonstrate the
model and results to shippers and carriers in the meat packing industry.  Of course, the model must be
tested more rigorously.  In 1991, the DOT conducted an origin-destination truck flow survey at 19
locations throughout the state.  The data were compiled and provided to us in an electronic OD format
which could be used to validate the Reebie OD data.  However, to validate the model loadings, the
location and timing of the surveys are needed.  This information was not provided and is presently being
requested.

Step 7: Forecast: A growth factor model will be used to update the OD table to future year levels.
Growth factors will be obtained from the State office of workforce development and ISU agricultural
economics researchers (origins), and census population forecasts (destinations).

Limitations of Selected Approach: 
Eventhough the methodology presented previously suits the need of the freight transportation

model it entails certain limitations, which include:
P Data requirements for validation
P Demand for truck transportation in one economic sector is ASSUMED independent of truck

transportation demand for other economic sectors
P Trucks assigned to transportation network from different industry sectors are ASSUMED to

interact independently with the transportation system
P Economic activity producing truck traffic is ASSUMED not to be uniformly distributed across an

entire region and concentrated within a few location.
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Chapter 5.  Impact on Iowa Department of Transportation

Implementation of a freight transportation model within the Iowa DOT may impact the
Department in several ways.  Model implementation may introduce new software and data sets to the
Department, existing software and data sets may need to be utilized in a new manner or by new users,
and the responsibilities of some Department personnel may change.  Eventhough most of these impacts
may be minor, they must still be addressed.  This chapter attempts to address the potential impacts by
reviewing pertinent databases and standards (from both within and outside of the Department) as well
as existing Department information systems and software.  Recommendations are provided regarding
element coordination.  Potential impacts on staff, hardware, and software are also outlined.

Iowa DOT Data, Databases and Standards
Base Record Inventory System.  The Base Record Inventory System is a hierarchical, static database
containing data on all road, structure, and railroad systems within the State of Iowa.  The data stored on
the inventory records are collected from various sources within and outside of the Iowa DOT.
Inventory records are updated continuously throughout the year in a database working file.  This file is
downloaded weekly to a variable length history format disk file.  A history file is created from the
database at the end of each year.

Highway data are stored as fixed-length, static segments in an IDMS database.  Segments are
created at locations of attribute changes and may be a minimum length of one-hundredth of a mile (ten
meters).

Bridge data are stored as Structure Inventory and Appraisal (SI&A) data and Supplemental
Structures Inventory (SSI) data.  SI&A data are collected for all the 25,500 bridges (4,000 primary,
21,500 secondary/municipal). These data include location, structure type, geometric data, condition and
appraisal ratings, load capacity, construction and rehabilitation data, proposed improvements, and
inspection dates. SSI data, containing condition information and maintenance/repair recommendations
for specific bridge elements, are collected only for the bridges on the primary system.

The Federal Railroad Association number is used to associate railroad crossing data with the
Base Record Inventory System.  These data include location, number of tracks, warning devices, trains
per day, maximum train speed, crossing angle, and sight distance. 

The Office of Transportation Data has initiated an effort to redesign the Base Record Inventory
System.  The primary focus of the redesign is integration of the base record database and graphics
(cartography) systems.  The system integration will facilitate more efficient user interaction with the
system as well as alleviate inconsistency between the graphics and the database.

Cartography.  City and county highway and transportation maps are maintained in electronic format (i.e.
MicroStation CAD) by the Office of Transportation Data.  These maps contain many natural,
man-made, and political features, such as rivers, roadway centerlines (interstate, primary, secondary,
and local), roadway structures, railroads, pipelines, airports, section lines, township boundaries, and
corporation limits.  The city maps are maintained at a 1:24,000 scale, while the county maps are
maintained at a 1:100,000 scale.

As with the base record inventory, cartographic data are updated throughout the year.  History
files for each city and county are created at the end of each year.  
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Relevance to Freight Planning Activity.  Currently, the highway model (second layer, meat packing
industry) is built from the cartographic files representing the primary state, US and interstate highways in
Iowa.  Only cartography (graphics) are currently used.  Once Base Records and cartography are
combined, the model will be able to access additional link information, beyond distance (which is
currently used to derive the model impedance).  Base Records will provide traffic and road condition
information potentially useful in improving the determination of freight flows.

Other Pertinent Data, Databases, and Standards 
TIGER.  The U.S. Census Bureau TIGER (Topologically Integrated Geographic Encoding and
Referencing) System database describes, mathematically, the geographic structure, location, and
relationship of streets, rivers, railroads, and the numerous geographic entities for which the Census
Bureau tabulates data from its censuses and sample surveys.  TIGER database extracts may be directly
linked with the 1990 decennial census data products (e.g summary tape files) using TIGER's digital
description of legal and statistical entities, including FIPS (Federal Information Processing Standards)
codes and Census Bureau codes (e.g. tract numbers).  TIGER data extracts are distributed by the
Census Bureau on compact disks in ASCII format.  In addition, several vendors have developed
translation modules which will convert TIGER extracts to software specific data formats (e.g. ArcInfo,
MGE, etc.).  Other vendors may sell TIGER data already converted.  The Iowa Department of Natural
Resources maintains several of the TIGER extracts in ArcInfo format, available on the World Wide
Web.   

Relevance to Freight Planning Activity.  The first "layer" of the model, grain flow, is being developed by
the ISU Economics Department and is based on TIGER.  TIGER and DOT cartography are similar
with regards to precision (both were derived from USGS DLGs) but differ primarily in their accuracy
(DOT files are considered to be more complete and up to date, with fewer errors.  TIGER has the
advantage of being attributed with information that allows ready linkage to Census summary data.  The
two systems can be translated via a process known as conflation, a mostly-automated process.

Employment.  The Iowa Department of Workforce Development maintains a database of employment
data for the State of Iowa which includes employer name and address, number of employees, and a
four digit Standard Industrial Code.  These data are private and can only be used internally by selected
agencies.  The native database used to maintain the employment data is not distributed, but the
Department of Workforce Development can distribute the data in ASCII format.

Relevance to Freight Planning Activity.  The layers (other than grain) use the employment database
extensively.

Freight Flow.  An extensive freight flow database is maintained by Reebie and Associates.  Freight
movements (in number of tons) are described by Standard Industrial Code (SIC), shipping mode, and
type of haul.  Movement origins and destinations are recorded by state and Business Economic Area

14



(BEA).  The native database used to maintain the freight flow data is not distributed, but Reebie and
Associates distributes the data of interest to Iowa in ASCII format, at a cost to the DOT.

Relevance to Freight Planning Activity.  Again, the Reebie database is used both to determine freight
origins and destinations and to validate fundamental modeling steps.

Nation-Wide Transportation Infrastructure.  Several vendors and governmental agencies maintain
nation-wide databases of transportation infrastructure.  Software vendors often offer such data in a
format compatible with their software.  Governmental agencies, such as the Federal Highway
Administration (FHWA) and the U.S. Geological Survey (USGS), also maintain nation-wide
geographic data sets of transportation infrastructure.  The FHWA provides geographic data files, in
ASCII format, which describe the national highway planning network, national principal rail network,
transit lines, principal hydrographic features, urbanized and national/state boundaries, major airports,
major Amtrak stations, major ports, priority 1 and 2 military bases, and major highway/rail transfer
facilities.  The USGS maintains several types of geographic data files including digital line graphs (DLG),
digital raster graphics (DRG), digital elevation models (DEM), and land use and land cover (LULC)
data.  Line data, such as roads and streams, are maintained in vector files (DLGs) digitized from USGS
topographic maps.

The USGS, and other, data sets are maintained and provided for various geographic extents at
various scales.  Therefore, tiling multiple data sets may be necessary to create a true nation wide
coverage.

Relevance to Freight Planning Activity.  A derivative of these national data sets, provided by MapInfo
Corp., was used to complete the model network (outside Iowa).

Information Systems and Software

The following is a description of Iowa DOT database systems and software which are or may be useful
to future freight planning or modeling efforts.

IDMS Database.  The IDMS database is a mainframe, hierarchical database with on-line update
capabilities.  Systems maintained in this database include the Base Record Inventory System, Parcel
Tracking System, as well as others.  Database access and user interfaces are controlled through on-line
applications, IDMS screen handling code, and batch processes.  Users may also apply SAS/ACCESS
against the database.  Data may be extracted from the IDMS database in ASCII, flat-file format.

ORACLE.  ORACLE is a relational database management system (RDMS).  Within the Iowa DOT,
ORACLE is primarily used in conjunction with MGE.  Data access, through both programs and user
interfaces, is accomplished through use of a set of commands called, structured query language (SQL).
SQL is the American National Standards Institute (ANSI) standard language for relational database
management systems.  In general, SQL is a non-procedural language with significant data manipulation
capabilities.  The data manipulating capabilities of SQL and the data processing capabilities of
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procedural languages are combined in SQL/PL.  Data may be extracted from the ORACLE database in
ASCII, flat-file format.

MGE (Modular GIS Environment).  MGE is a full-function geographic information system (GIS).  It is a
computerized database management system for capturing, storing, retrieving, analyzing, and displaying
spatial data.  MGE has been used at the Iowa DOT in a demonstration project and is currently being
used in mapping applications, work with the primary road system, and the non-NHS, Federal aid
eligible pavement management project.  MGE is built on several software applications, including MGE
Base Mapper (MGMAP), MGE Basic Nucleus (MGNUC), MGE Basic Administrator (MGAD),
Relational Interface System (RIS), Relational database (e.g. ORACLE), and MicroStation.

RIS (Relational Interface System).  RIS is a generic relational database interface, permitting network
access to popular RDMSs.  Applications and users are isolated from the difference in different vendors
RDBMs.  RIS is used at the Iowa DOT as the interface between ORACLE and MGE.

MicroStation.  MicroStation is computer aided drafting and design (CADD) software.  MicroStation
may be used for drafting, design, visualization, database management, and modeling in two or three
dimensions.  Several offices within the Iowa DOT utilize MicroStation, such as Transportation Data,
Right of Way, Maintenance, and Design.  All Iowa DOT cartography files are maintained in
MicroStation format.  MicroStation is also used in conjunction with MGE.

MapInfo.  MapInfo is a desktop mapping tool.  Some of MapInfo's capable include performing
geographic and attribute analyses, creating thematic maps, and linking to remote databases.  MapInfo
may be customized and automated using the software product, MapBasic.  The Office of Systems
Planning is currently using MapInfo, and other offices may begin using it in the future.  Note: MapInfo is
currently being used in this project phase to host the modeling environment.

TRANPLAN.  TRANPLAN is a computerized urban travel demand model, based on the traditional,
four step, transportation forecasting model.  The primary function of TRANPLAN is analysis of
multi-modal transportation systems.  Inputs into TRANPLAN include ASCII files describing the
transportation network and travel demand.  The Office of Systems planning currently uses
TRANPLAN, and the Iowa DOT maintains a statewide TRANPLAN license.  Note: Tranplan is being
used to perform traffic assignment to state roads in the current modeling phase (meat packing industry).
Its trip generation, distribution and mode split capabilities may be useful in future development (other
commodity layers).

Coordination Elements Recommendation
In 1994 the Iowa DOT established Work Plans for the development of seven transportation

management and traffic monitoring systems as required by the Intermodal Surface Transportation
Efficiency Act (ISTEA) of 1991.  These systems include pavement management, bridge management,
highway safety management, congestion management, public transportation facilities and equipment
management, intermodal management, and traffic monitoring system.  As these management and
information systems continue to be developed, data access between systems is becoming more critical,
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and duplication of effort in data collection is becoming a greater concern.  The Iowa DOT has initiated
an effort to establish coordinated databases for the management systems which will support the
investment decisions of the Department and local governments for future transportation infrastructure in
the State of Iowa.

Integration of the management system data through coordinated databases may be
accomplished through use of GIS (geographic information systems).  In fact, a GIS Strategic Plan was
prepared for the Department in 1994 to promote and guide the development of applications in the
Department to the point where GIS begins to pay off by streamlining analysis to support decisions.  This
plan states that GIS can and should serve as a tool of integrating the data for use across the
Department.

Like the management systems, freight transportation modeling may influence infrastructure
investment decisions; but, unlike the management systems, freight modeling may be used to assess the
impacts (on freight flows) of management system driven policy changes.  GIS can greatly facilitate these
impact analyses.  Furthermore, management systems and freight transportation models will likely utilize
common data elements, such as highway and structure data stored in the Base Record Inventory
System.  Therefore, the redesign of the base records should be of significant interest as well.  The first
stage integration efforts are already being used to develop a base highway network for the State
non-NHS, Federal aid eligible pavement management system (about 20,000 of the State's 110,000
miles of road).

Database coordination as well as active involvement in ongoing GIS implementation efforts and
base record redesign may all be instrumental in the future success of freight transportation modeling in
the Department.

Staff, Training, and Resources
Upon development of the freight transportation planning procedures and model, users (from

within the Office of Systems Planning staff) must be identified.  These individuals should receive
thorough training on the modeling process, model data elements (access and utilization), and software
application.

Model implementation may also entail acquiring new software and data sets at the Iowa DOT,
or existing software and data sets may need to be utilized in a new manner.  Therefore, interaction with
the automation support staff and database administrators (Office of Data Services) will be necessary.
Issues that need to be resolved include who will support model software, who will maintain model data,
and where will model data be maintained.  If model software and data are not to be accessed through
the Iowa DOT LAN, it may be necessary to dedicate hardware for use in freight transportation
modeling.  Appropriate model software and data would reside locally on the dedicated PC(s), and that
PC could then be used for freight modeling as well other Systems Planning work tasks.

As a whole, the potential impacts of freight transportation modeling on the Department seem
minor. The greatest impact may be experienced in the need to define and, in some cases, redefine data
access and utilization procedures.  However, this is quite synergistic with the Department's efforts to
establish coordinated management systems and redesign the Base Record Inventory System.  Coordi-
nation of these efforts may, in fact, impact the Department in a positive manner, with both freight model
users and Department data users in general benefiting.
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Chapter 6.  Conclusions

The freight transportation demand model developed for this project was based on the principal
of layers.  The pilot model performed well in initial tests and appears to have satisfied the stated
objectives.  First, the State's freight transportation infrastructure was characterized as a truck highway
system consisting of the primary highways within Iowa and Interstate highways outside of Iowa.  The
locations of Iowa's freight-oriented industries were determined using IDWD employment data, and
Reebie and Associates freight data, factored to the county level within Iowa, were used to characterize
significant commodity/freight movements.  Commodity movements were determined to move chiefly to
large markets by the shortest path.

A GIS base network assignment model was developed to respond to policy and industry
changes.  For example, public investment initiatives, such as the addition of facilities, services, or
improvements, are represented by the addition of a link in the network.  By increasing the cost on all
links in Iowa, other pubic initiates (higher road use fees) are also represented.  Changing transport
prices are modeled as an increase in the total cost function or cost of the fuel component.  Changes in
industry locations, including growth, decline, and relocation, are accounted for by applying growth
factors to trip ends.  Lastly, link impedance are modified, or links are removed, to model restrictions on
routes, such as weight limits and truck routes.

The sensitivity of the model to policy decisions reflects how Iowa's economic position by
commodity relates to or is impacted by transportation services in the State.  Currently, the model may
be used to identify transportation facilities (infrastructure) of importance.

Several of the functions and capabilities of the freight transportation model discussed here
satisfy, address, or are germane to the Department's stated future priorities.  These priorities follow:

P Develop tools to include all modes, intermodal solutions, or impacts as opposed to a only truck
model.

P Investigate use of other modeling approaches (in addition to travel models).
P Use the model (presented here) and other technologies to identify significant commodity/frieght

movements in Iowa.
P Analyze reasons, if any, that freight oriented industries locate in Iowa.  Identify what types of

industries are attracted to rural and urban Iowa, what industries are shifting to other areas of the
United States, and other trends.  This should include a general discussion of Iowa's economic
position by commodity in the nation, and how it relates to, or is impacted by, the transportation
services in Iowa, the midwest region, and beyond.

P Identify, quantify, and evaluate the freight infrastructure in the state (highway system/truck
volumes, rail system/ton-miles, air freight facilities, river/barge movements, intermodal transfer
facilities/usage levels).  Analyze how the various commodities are moving and why. Investigate
and identify the transportation and non-transportation variables that determine how commodities
are shipped.  These efforts will establish the relational groundwork for future models to be
developed.

P Identify existing and potential issues in Iowa, and how each could be impacted by the Department
through planning activities leading to infrastructure investments or other initiatives.  This would
provide an analysis of how public policy can and cannot impact freight issues.
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P Enhance the model (presented here) so the Iowa DOT can simulate the impact of changes in the
transportation and non-transportation service variables.  Variables may include but are not are
limited to: increased or decreased public and/or private investments in one or more modes;
revised pricing of shipments by rail, air, barge, truck, or other modes; fluctuation of fuel costs;
shifts, increases, or decreases of industries within the State; revisions to restrictions such as truck
weight/length limits, speed limits, and route restriction; impact of improved truck flow due to
highway improvements such as widening and bypass projects.

Although several of these priorities may be addressed using the freight transportation model
presented here, this does not suggest that it is the only freight modeling strategy the Iowa DOT should
implement.  Application of this model, enhancement of this model, future model development, and
freight transportation analysis in general should all be approached from within the framework of these
priorities.
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Products Developed by Project

The products developed during the working of the project are listed below with a brief descrip-
tion of each.  Each product is put into one appendix to categorize them. 

P Appendix A provides a developers guide that illustrates the development of a node link network
and the development of the model using the employment and population ratios.

P Appendix B provides a users guide that help the user in running the already constructed model
and lets the user perform what-if questions.
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Appendix A

Developers Guide for the Statewide Freight Transportation Model 

This guide describes the development of the statewide model for freight developed for the

Iowa DOT by the ISU Center for Transportation Research and Education. To create this model the

following requirements are necessary:

Hardware Requirements:

1. PC with DOS and windows 3.x (currently non compatible with windows 95)

software requirements:

1. TranPlan

2. MapInfo 3.0 or higher

3. FORTRAN 77

4. Any text editor

The model uses data during its execution. These data include data from the Department of

Employment Services, Reebie associates and Department of Natural Resources. A brief overview

of the topics and the methodology is needed in understanding the running of the model and the

terminology used in the workings of the model. 

The model building consists of two major steps, at first the network consisting of the node

and link network is to be established and second the so constructed model needs to be run to

obtain the flows. A network suitable to the level of detail required for the model is chosen and

adequate manipulation is done to give it compatibility with TranPlan. The manipulation consists of



running a series of computer program with the network as input and then producing the output

needed. Detailed description of the effort involved is provided further on in the guide.

The second step of the model will involve extracting data from computer files. The working

of the data will use employment ratios that are the ratios of employment in a particular county and

employment in the BEA that overlap it. Likewise population ratios are ratios of population. Detailed

descriptions are provided later.

The importance of each and their use is described in the following sections.

1. DES Data

2. Creating Employment and Population Proportions

3. Reebie Data

4. Formation of OD Matrix

5. Editing TranPlan input files

6. Running the Interface

 This Guide also describes the construction of the link/node network building required by

the model.

1. DES Data: Data relating to employment in different industry groups for the state, divided

into counties was obtained on 9 inch tapes in the form of text files. The data describes each

employer by name, address, commodity group and the number of employees. The data were used

to obtain employment ratios that are used in the model to distribute origin data to the counties. 



The procedure consists of copying employment data from the counties table to the taz table

for each commodity type. A commodity type is represented by the Standard Industrial Code (SIC)

code. 

To prepare the DES data for use in the model, the following steps are to be followed:

a. Choose File > open table from the Menu bar of MapInfo and open table

g:\_project\statemod\freight\counties.tab 

b. Likewise, open table g:\_project\statemod\tp\taz.tab

c. From the MapInfo menubar choose Table > Update Column. Select the column

"employment" as the column to be updated in the table taz from the column "sic_201 " from the

counties, where fips_code in the taz layer is equal to county_number in the counties layer.

d. Choose File > close from the MapInfo menu bar and close table "counties.tab"



2. Creating Employment Proportions: As mentioned above the data are copied from the

counties table. These data are absolute figures for each county. In order to distribute these data to

the origins from each county as a subset of a BEA there is need to create employment ratios.

To create the ratios use the following steps

a. Open tables g:\_project\statemod\tp\new_bea.tab and g:\_project\statemod\tp\taz.tab

b. Choose Table > Update Column to get the update column dialog box. Update the

column emp_bea in the TAZ layer from the new_bea table, where the condition is that the object in

the  taz layer is within the new_bea layer.



c. Choose Table > Update Column and update the emp_ratio column as

employement/emp_bea.

d. The pop_ratio column does not need to changed.

3. Reebie Data: Reebie and Associates collects and maintains an extensive nationwide

freight flow (OD) database.  The data are organized by Business Economic Areas (BEA)

designated by the Department of Commerce.  Each BEA typically represents a major economic

center (for example, there are six BEAs in Iowa). The Reebie data provided for this project include

origin state, origin BEA and destination state, destination BEA for each OD pair. The data are

further classified by commodity type (SIC) and shipping mode. Truck flows are classified by type of

carrier (for-hire, private) and by shipment type (container, bulk, or LTL).



The Reebie data are stored in a Lotus Approach database. There is need to find the

records that belong to the particular industry group and then export the data in the form of a text file.

The data that are exported should have all the trip purposes for the commodity. 

To extract the Reebie data in a form usable by the model. Do the following procedure: 

a. Open Lotus Approach database and then choose File/Open from the menu bar. Open

database g:\_project\statemod\reebie\ra1385.apr

b. Click the button to select records.

c. Click in the "commodity" column and type "201", then hit enter. The database selects and

displays the records with commodity 201 (which is meat).

d. Choose File/Export Data, this displays the Export dialog box. 

e. Choose the columns to exported in the bottom-left corner. The columns are  that need to

be exported are origin_state, origin_bea, dest_state, dest_bea, commodity,  hireconttons,

hirebulktons, LTL tons,  privconttons, privbulktons.

f. Click and choose the file type to be text delimited and click OK. A separate dialog box

appears where you can specify space as a separation field.

g. Type the name of the file to be reebie.txt. If you happen to have another file with the

same name, you may want to move it under a different name. Then hit enter or click the OK button.

h. Exit Lotus Approach by choosing File > Exit.



4. Formation of OD Matrix: The Reebie Data is in the form of a OD matrix that is not in

conjunction with TranPlan input requirements. To change the data, a FORTRAN program called

"matrix.exe" is used. Additionally, this program also breaks the Reebie BEA level data to county

level data, for BEAs intersecting Iowa. The program takes the Reebie data file and the TAZ layer

data file as input and outputs matrices for five different trip purposes compatible to TranPlan.

To modify the selected Reebie data into a form readable by TranPlan adopt these steps:

a. Open FORTRAN 77 and choose File > Open to open g:\_project\statemod\tp\matrix

b. Choose Project > Execute matix.Exe and execute the file. The execution stops

automatically.

c. Exit FORTRAN by choosing File > Exit.



d. The output file are stored under the same directory as the executable and will be called

matrix1.txt through matrix5.txt

e. Make sure that the input files needed by this program viz. reebie.txt and map.txt are in the

same directory as the executable.

5. Editing the TranPlan Input files: The model has been constructed to handle each trip

purpose at a time. Therefore it is essential that to obtain the loadings for the entire industry sector, all

five purposes are to loaded. TranPlan uses a input file that describes trip purposes in its input. This

file is called  "network.in" and has to be stored in the same directory as the rest of the files. 

a. Open File Manager and locate the TranPlan input file network.in.

b. Open it in a text editor and edit the name the name of the input file mentioned there as

matrix1 or matrix2 etc. depending on the trip purpose needed for modeling.

c. It is helpful to create five different files with five different input files for trip purposes and

saving them accordingly to save time during execution.



6. Run Interface: Once the above five steps have successfully been performed, all the input

needed to run the interface are completed. The actual running of the interface and the model is

described below:

a. In MapInfo close all files. 

b. Open tables g:\_project\statemod\tp\links.tab and g:\_project\statemod\tp\nodes.tab



c. Choose File > Run MapBasic Program from the menubar and select "statemod.mbx"

from the dialog box

d. When the program starts executing the first dialog box asks you to confirm if you have

run the interface before for the same link\node network. Click NO for the first trip purpose,

subsequent runs click YES.

e. Type the name of the link file which is "links" when it prompts for the input and click OK

or hit enter. Likewise type in the name of the nodes file which is "nodes" when it prompts for the

input and click OK or hit enter.

f. As a next step the program takes you to the DOS prompt. At the prompt, type in "netbld"

and hit enter.



g. After execution is completed type "exit" and hit enter to return to the MapInfo main

screen. Click on OK on the note that appears after reading it.

h. The TranPlan menu opens up. Click Open and Browse through the directory options and

double click on your working directory. In the file options that appear on the right side, double click

on "netbld.in". Now click run.

i. After the execution is completed, double click on "network.in" in the file options and click

run.

j. Exit TranPlan after the program has executed.

k. Click OK on the note box which appears.

l. The TranPlan utility menu appears. Click on Open and Browse through the directory list

and double click on the working directory.



m. Choose the NETCARD utility from the utility browse and double click. A input window

appears. Type "out.bin" for input file name and hit enter, type "out.dat' for output file name and hit

enter. Then enter N, N, N, Y while hitting enter for each of the subsequent questions in order.

n. The program brings you back to MapInfo. Click on OK on the dialog box displayed for

instructions. 

o. The program takes you to the DOS prompt. Type "loaded" and hit enter. Exit the DOS

prompt after execution. 

p. Click OK on the dialog box that appears after reading. The program automatically

updates the links file with information obtained from the TranPlan run.



Creation of the Link/Node Network:

Preparation: Obtain the basic map of the Traffic Analysis Zones (TAZ) to be used in

TRANPLAN. Also obtain the road network that is to be used. Mark Centroids on the TAZ map.

Then split a link nearest to the centroid and attach a connector to the centroid. This process will be

done manually. Care is to be taken that the centroid connectors are attached to the network exactly

at the point of split. This is important on two accounts:

(a) If the centroid connector is attached at a point other than the point of split, three 

     instead of two links are formed from the one link. 

(b) Magnify or zoom in to see that the connector has been attached properly. If it is not

connected, the connector is left hanging and TRANPLAN will not be able to allocate any flows to

the link.

Programs: The following programs are to be executed sequentially:

1. CR_TOP2.MB:  It is a MAPBASIC program that takes the network as input. Then it goes in

and assigns ax, ay, bx, by, length and linkid to each link. It also creates a_node and b_node fields in

the table. The linkid is maintained the same as the row number. Each object is checked for being a

polyline or a line and assigns nodes accordingly. The output is in the form of a ASCII text file with

space delimiter.

2. CR_NODES.FOR: The output of the earlier program is used as the input for this program. It

creates a node matrix i.e. It assigns a node number to a particular x,y pair. The output  is a text file

with the node number, X and Y.



3. NOD4LINKS.FOR: The program takes the same input as the CR_NODES.FOR and its

output. The program then compares the X,Y pairs in both the text files and outputs a_node, b_node

and linkid. The a_node and b_node are used to populate the original table. 

4. UPDATE.MB: This program gives us the result. It populates a_node, b_node fields. It also

creates a new file with graphic coverage of nodes and their X,Y.



Appendix B

              User Guide for the Statewide Freight

Transportation Model



This guide describes use of the statewide model for freight developed for the Iowa DOT by the

ISU Center for Transportation Research and Education and will help the user with running the model

and be able to answer what-if questions posed by the user.  To run the model the following

requirements are necessary:

Hardware Requirements:

1. PC with DOS and windows 3.x  (currently non compatible with windows '95)

software requirements:

1. TranPlan

2. MapInfo 3.0 or higher

3. FORTRAN 77

4. Any text editor

The model uses data during its execution that include data from the Department of Employment

Services, Reebie associates and Department of Natural Resources.  A brief overview of the topics and

the methodology is needed in understanding the running of the model and the terminology used in the

workings of the model and is provided below. 

The model building consists of two major steps, at first the network consisting of the node and

link network is to be established and second the so constructed model needs to be run to obtain the

flows.  A network suitable to the level of detail required for the model is chosen and adequate

manipulation is done to give it compatibility with TranPlan.  The manipulation consists of running a series

of computer program with the network as input and then producing the output needed.  Detailed

description of the effort involved is provided further on in the guide.



Some of the what-if questions or scenarios and the methodologies used to answer them  include:

{ removing a link from the network  

{ removing a node from the network

{ Changing speeds on links 

{ rerunning the model

Removing a link from the network

When a link is removed from the network, the principal consideration is to populate the network

tables once again and subsequently to obtain the effects of this removal on the flows.   A link may be

removed from the network to check effects on flow patterns (e.g. what happens if a particular road is

abandoned).   The procedure to be followed in removing a link and obtaining fresh flows is as follows:

a.  In MapInfo open the table containing the network.

b.  Choose Map > Layer Control.  In the dialog box, click on the network layer and make it

editable by clicking on the edit button.  Click OK to exit.



choose Edit > Cut to remove the link from the table.



d.  Choose Table > Maintenance > Pack Table to view the Pack Table dialog box.  Choose

edit both type of data and click OK.  

f.  It is most important to note that when you delete a link make sure that there is no node that

has no link attached to it, i.e.  do not leave a node hanging or "orphan".  If this occurs a fatal error will

TranPlan.  If it so happens that when you delete a link an orphan node is formed, the node

g.  Rerun the interface.

Removing a node from the network



the effects of this removal on the flows.  A node may be removed from the network following a link

removal.  The procedure to be followed in removing a node is as follows:

b.  Select the node by clicking on it and delete the node (similar to deleting a link).

c.  Pack the table and save it.

Changing speeds on links 

centroid connectors have been set at 65

pattern.  A scenario might be when trying to find effect of speed on the shipment of a commodity on a

given facility.

a.  Open the links table.

b.  Choose Query > Select.  In the dialog box click on Assist button and browse the columns to

"interst".

c.  When the  appears in the expression window, type "=1" and click OK.  



d.  Click OK again to exit the select dialog box and browse the results.  

e.  Choose Table > Update Column .  In the dialog box choose "time1" as the column to be

updated.  

f.  Click Assist and choose length from the columns.  In the Type Expression window type

"*100/speed in kmph".



g.  Click OK to exit the Assist window and click OK again to exit the update column window.  

h.  Update the Column "time3" in a similar way.

i.  Save the table and follow and rerun the interface.

Rerunning the model

There will be need to rerun the interface whenever there is need to do any simulation.  The

actual running of the interface and the model is described below:

a.  In MapInfo close all files.  

b.  Open tables g:\_project\statemod\tp\links.tab and g:\_project\statemod\tp\nodes.tab

c.  Choose File > Run MapBasic Program from the menubar and select "statemod.mbx" from

the dialog box



the interface before for the same link\node

network.

e.  Type the name of the link file which is "links" when it prompts for the input and click OK or

click OK or hit enter.

f.  As a next step the program takes you to the DOS prompt.  At the prompt, type in 

and hit enter.

g.  After execution is completed type "exit" and hit enter to return to the  main screen.

Click on OK on the note that appears after reading it.

TranPlan menu opens up.  Click Open and Browse through the directory options and

"netbld.in".  Now click run.

"network.in" in the file options and click

j.  Exit TranPlan

k.  Click OK on the note box which appears.

l.  The  utility menu appears.  Click on Open and Browse through the directory list and

double click on the working directory.

NETCARD utility from the utility browse and double click.  A input window

"out.bin" for input file name and hit enter, type  for output file name and hit

enter.  Then enter N, N, N, Y while hitting enter for each of the subsequent questions in order.



n.  The program brings you back to MapInfo.  Click on OK on the dialog box displayed for

instructions.  

o.  The program takes you to the DOS prompt.  Type "loaded" and hit enter.  Exit the DOS

prompt after execution.  

p.  Click OK on the dialog box that appears after reading.  The program automatically updates

the links file with information obtained from the TranPlan run.


